$re = '/<h6 class="event-title">(.+?)<\/h6>/m';
$str = '<h6 class="event-title">Brisbane Lions v Hawthorn Football Club and Anthing else we wish here including @#$%^&*(</h6>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);