#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(?\+?(?:\d{3})?\)?[-. ]?(?!(\d)\1{9})\d{10}$"
Local $sString = "(+123)-1234567890" & @CRLF & _
"(+123)-1111111111" & @CRLF & _
"(+123)-9999999999" & @CRLF & _
"(+123) 1234567890" & @CRLF & _
"(123)-1234567890" & @CRLF & _
"-1234567890" & @CRLF & _
"1234567890" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")