const regex = /^\(?\+?(?:\d{3})?\)?[-. ]?(?!(\d)\1{9})\d{10}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\(?\\+?(?:\\d{3})?\\)?[-. ]?(?!(\\d)\\1{9})\\d{10}$', 'gm')
const str = `(+123)-1234567890
(+123)-1111111111
(+123)-9999999999
(+123) 1234567890
(123)-1234567890
-1234567890
1234567890
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}