re = /^\(?\+?(?:\d{3})?\)?[-. ]?(?!(\d)\1{9})\d{10}$/m
str = '(+123)-1234567890
(+123)-1111111111
(+123)-9999999999
(+123) 1234567890
(123)-1234567890
-1234567890
1234567890
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end