import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(?\\+?(?:\\d{3})?\\)?[-. ]?(?!(\\d)\\1{9})\\d{10}$";
final String string = "(+123)-1234567890\n"
+ "(+123)-1111111111\n"
+ "(+123)-9999999999\n"
+ "(+123) 1234567890\n"
+ "(123)-1234567890\n"
+ "-1234567890\n"
+ "1234567890\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}