using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(?\+?(?:\d{3})?\)?[-. ]?(?!(\d)\1{9})\d{10}$";
string input = @"(+123)-1234567890
(+123)-1111111111
(+123)-9999999999
(+123) 1234567890
(123)-1234567890
-1234567890
1234567890
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}