package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{2}\/\d{2}\/\d{2} \d{2}:\d{2}:\d{2}:\d{3}`)
var str = `26/10/22 20:36:22:385 SCOPE: SYSTEM ID: ALL
26/10/22 20:36:22:385 ELAPSED_TIME: 61.7 s
26/10/22 20:36:22:385 EMM_PROCEDURE:
26/10/22 20:36:22:385 [Procedure] [Count] [Retry] [Success] [Failure]
26/10/22 20:36:22:385 ATTACH 0 0 0 0
26/10/22 20:36:22:385 DETACH_UE_INIT 0 0 0 0
26/10/22 20:36:22:385 DETACH_NW_INIT 0 0 0 0
26/10/22 20:36:22:385 TAU_NORMAL 0 0 0 0
26/10/22 20:36:22:385 TAU_PERIODIC 0 0 0 0
26/10/22 20:36:22:385 SERVICE_REQ_MO 0 0 0 0
26/10/22 20:36:22:385 SERVICE_REQ_MT 0 0 0 0 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}