import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2}\\/\\d{2}\\/\\d{2} \\d{2}:\\d{2}:\\d{2}:\\d{3}";
final String string = "26/10/22 20:36:22:385 SCOPE: SYSTEM ID: ALL\n"
+ "26/10/22 20:36:22:385 ELAPSED_TIME: 61.7 s\n"
+ "26/10/22 20:36:22:385 EMM_PROCEDURE:\n"
+ "26/10/22 20:36:22:385 [Procedure] [Count] [Retry] [Success] [Failure]\n"
+ "26/10/22 20:36:22:385 ATTACH 0 0 0 0 \n"
+ "26/10/22 20:36:22:385 DETACH_UE_INIT 0 0 0 0 \n"
+ "26/10/22 20:36:22:385 DETACH_NW_INIT 0 0 0 0 \n"
+ "26/10/22 20:36:22:385 TAU_NORMAL 0 0 0 0 \n"
+ "26/10/22 20:36:22:385 TAU_PERIODIC 0 0 0 0 \n"
+ "26/10/22 20:36:22:385 SERVICE_REQ_MO 0 0 0 0 \n"
+ "26/10/22 20:36:22:385 SERVICE_REQ_MT 0 0 0 0 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}