const regex = new RegExp('\\d{2}\\/\\d{2}\\/\\d{2} \\d{2}:\\d{2}:\\d{2}:\\d{3}', 'gm')
const str = `26/10/22 20:36:22:385 SCOPE: SYSTEM ID: ALL
26/10/22 20:36:22:385 ELAPSED_TIME: 61.7 s
26/10/22 20:36:22:385 EMM_PROCEDURE:
26/10/22 20:36:22:385 [Procedure] [Count] [Retry] [Success] [Failure]
26/10/22 20:36:22:385 ATTACH 0 0 0 0
26/10/22 20:36:22:385 DETACH_UE_INIT 0 0 0 0
26/10/22 20:36:22:385 DETACH_NW_INIT 0 0 0 0
26/10/22 20:36:22:385 TAU_NORMAL 0 0 0 0
26/10/22 20:36:22:385 TAU_PERIODIC 0 0 0 0
26/10/22 20:36:22:385 SERVICE_REQ_MO 0 0 0 0
26/10/22 20:36:22:385 SERVICE_REQ_MT 0 0 0 0 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}