import re
regex = re.compile(r"\d{2}\/\d{2}\/\d{2} \d{2}:\d{2}:\d{2}:\d{3}", flags=re.MULTILINE)
test_str = ("26/10/22 20:36:22:385 SCOPE: SYSTEM ID: ALL\n"
"26/10/22 20:36:22:385 ELAPSED_TIME: 61.7 s\n"
"26/10/22 20:36:22:385 EMM_PROCEDURE:\n"
"26/10/22 20:36:22:385 [Procedure] [Count] [Retry] [Success] [Failure]\n"
"26/10/22 20:36:22:385 ATTACH 0 0 0 0 \n"
"26/10/22 20:36:22:385 DETACH_UE_INIT 0 0 0 0 \n"
"26/10/22 20:36:22:385 DETACH_NW_INIT 0 0 0 0 \n"
"26/10/22 20:36:22:385 TAU_NORMAL 0 0 0 0 \n"
"26/10/22 20:36:22:385 TAU_PERIODIC 0 0 0 0 \n"
"26/10/22 20:36:22:385 SERVICE_REQ_MO 0 0 0 0 \n"
"26/10/22 20:36:22:385 SERVICE_REQ_MT 0 0 0 0 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")