// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{2}\/\d{2}\/\d{2} \d{2}:\d{2}:\d{2}:\d{3}").unwrap();
let string = "26/10/22 20:36:22:385 SCOPE: SYSTEM ID: ALL
26/10/22 20:36:22:385 ELAPSED_TIME: 61.7 s
26/10/22 20:36:22:385 EMM_PROCEDURE:
26/10/22 20:36:22:385 [Procedure] [Count] [Retry] [Success] [Failure]
26/10/22 20:36:22:385 ATTACH 0 0 0 0
26/10/22 20:36:22:385 DETACH_UE_INIT 0 0 0 0
26/10/22 20:36:22:385 DETACH_NW_INIT 0 0 0 0
26/10/22 20:36:22:385 TAU_NORMAL 0 0 0 0
26/10/22 20:36:22:385 TAU_PERIODIC 0 0 0 0
26/10/22 20:36:22:385 SERVICE_REQ_MO 0 0 0 0
26/10/22 20:36:22:385 SERVICE_REQ_MT 0 0 0 0 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}