package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:0*1)*(?:00)+$`)
var str = `0
1
00
01
010
0100
01000
110000
1100100
11001001
110010010
1100100100
10110010000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}