import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0*1)*(?:00)+$";
final String string = "0\n"
+ "1\n"
+ "00\n"
+ "01\n"
+ "010\n"
+ "0100\n"
+ "01000\n"
+ "110000\n"
+ "1100100\n"
+ "11001001\n"
+ "110010010\n"
+ "1100100100\n"
+ "10110010000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}