$re = '/^(?:0*1)*(?:00)+$/m';
$str = '0
1
00
01
010
0100
01000
110000
1100100
11001001
110010010
1100100100
10110010000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);