re = /^(?:0*1)*(?:00)+$/m
str = '0
1
00
01
010
0100
01000
110000
1100100
11001001
110010010
1100100100
10110010000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end