// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0*1)*(?:00)+$").unwrap();
let string = "0
1
00
01
010
0100
01000
110000
1100100
11001001
110010010
1100100100
10110010000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}