#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)/(\w+)/(\w+)/(\w+)\..{3}$"
Local $sString = "c:/my_project/sources/hr/spec/manage_employees.sql" & @CRLF & _
"c:/my_project/sources/hr/body/manage_employees.sql" & @CRLF & _
"c:/my_project/sources/hr/type_spec/employee_typ.sql" & @CRLF & _
"c:/my_project/sources/hr/type_body/employee_typ.sql" & @CRLF & _
"c:/my_project/sources/hr/trigger/employees_after_each.sql" & @CRLF & _
"c:/my_project/tests/hr/spec/test_manage_employees.sql" & @CRLF & _
"c:/my_project/tests/hr/body/test_manage_employees.sql" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")