import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/(\\w+)/(\\w+)/(\\w+)\\..{3}$";
final String string = "c:/my_project/sources/hr/spec/manage_employees.sql\n"
+ "c:/my_project/sources/hr/body/manage_employees.sql\n"
+ "c:/my_project/sources/hr/type_spec/employee_typ.sql\n"
+ "c:/my_project/sources/hr/type_body/employee_typ.sql\n"
+ "c:/my_project/sources/hr/trigger/employees_after_each.sql\n"
+ "c:/my_project/tests/hr/spec/test_manage_employees.sql\n"
+ "c:/my_project/tests/hr/body/test_manage_employees.sql\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}