const regex = new RegExp('/(\\w+)/(\\w+)/(\\w+)\\..{3}$', 'gm')
const str = `c:/my_project/sources/hr/spec/manage_employees.sql
c:/my_project/sources/hr/body/manage_employees.sql
c:/my_project/sources/hr/type_spec/employee_typ.sql
c:/my_project/sources/hr/type_body/employee_typ.sql
c:/my_project/sources/hr/trigger/employees_after_each.sql
c:/my_project/tests/hr/spec/test_manage_employees.sql
c:/my_project/tests/hr/body/test_manage_employees.sql
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}