// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/(\w+)/(\w+)/(\w+)\..{3}$").unwrap();
let string = "c:/my_project/sources/hr/spec/manage_employees.sql
c:/my_project/sources/hr/body/manage_employees.sql
c:/my_project/sources/hr/type_spec/employee_typ.sql
c:/my_project/sources/hr/type_body/employee_typ.sql
c:/my_project/sources/hr/trigger/employees_after_each.sql
c:/my_project/tests/hr/spec/test_manage_employees.sql
c:/my_project/tests/hr/body/test_manage_employees.sql
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}