use strict;
my $str = 'c:/my_project/sources/hr/spec/manage_employees.sql
c:/my_project/sources/hr/body/manage_employees.sql
c:/my_project/sources/hr/type_spec/employee_typ.sql
c:/my_project/sources/hr/type_body/employee_typ.sql
c:/my_project/sources/hr/trigger/employees_after_each.sql
c:/my_project/tests/hr/spec/test_manage_employees.sql
c:/my_project/tests/hr/body/test_manage_employees.sql
';
my $regex = qr~/(\w+)/(\w+)/(\w+)\..{3}$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}