re = /\/(\w+)\/(\w+)\/(\w+)\..{3}$/m
str = 'c:/my_project/sources/hr/spec/manage_employees.sql
c:/my_project/sources/hr/body/manage_employees.sql
c:/my_project/sources/hr/type_spec/employee_typ.sql
c:/my_project/sources/hr/type_body/employee_typ.sql
c:/my_project/sources/hr/trigger/employees_after_each.sql
c:/my_project/tests/hr/spec/test_manage_employees.sql
c:/my_project/tests/hr/body/test_manage_employees.sql
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end