#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(logger.error\("*)(.+)("*,)(.+)(\);)"
Local $sString = "logger.error("error message", qq);" & @CRLF & _
"logger.error("error message", qt);" & @CRLF & _
"logger.error("error message",qt);" & @CRLF & _
"logger.error("error ",qt);" & @CRLF & _
"logger.error(message,ner);"
Local $sSubst = "\1\2\3ex\5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)