import re
regex = re.compile(r"(logger.error\(\"*)(.+)(\"*,)(.+)(\);)")
test_str = ("logger.error(\"error message\", qq);\n"
"logger.error(\"error message\", qt);\n"
"logger.error(\"error message\",qt);\n"
"logger.error(\"error \",qt);\n"
"logger.error(message,ner);")
subst = "\\1\\2\\3ex\\5"
result = regex.sub(subst, test_str)
if result:
print(result)