// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(logger.error\("*)(.+)("*,)(.+)(\);)"#).unwrap();
let string = "logger.error(\"error message\", qq);
logger.error(\"error message\", qt);
logger.error(\"error message\",qt);
logger.error(\"error \",qt);
logger.error(message,ner);";
let substitution = "\\1\\2\\3ex\\5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}