import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(logger.error\\(\"*)(.+)(\"*,)(.+)(\\);)";
final String string = "logger.error(\"error message\", qq);\n"
+ "logger.error(\"error message\", qt);\n"
+ "logger.error(\"error message\",qt);\n"
+ "logger.error(\"error \",qt);\n"
+ "logger.error(message,ner);";
final String subst = "\\1\\2\\3ex\\5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}