re = /(logger.error\("*)(.+)("*,)(.+)(\);)/
str = 'logger.error("error message", qq);
logger.error("error message", qt);
logger.error("error message",qt);
logger.error("error ",qt);
logger.error(message,ner);'
subst = '\\1\\2\\3ex\\5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result