use strict;
my $str = 'logger.error("error message", qq);
logger.error("error message", qt);
logger.error("error message",qt);
logger.error("error ",qt);
logger.error(message,ner);';
my $regex = qr/(logger.error\("*)(.+)("*,)(.+)(\);)/p;
my $subst = '\\1\\2\\3ex\\5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";