#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\[2\][^=]+?= "").*(?="")"
Local $sString = "[0]" & @CRLF & _
" 1 string data = " & @CRLF & _
"[1]" & @CRLF & _
" 1 string data = "first spanish text"" & @CRLF & _
"[2]" & @CRLF & _
" 1 string data = ""some text""" & @CRLF & _
"[0]" & @CRLF & _
" 1 string data = """ & @CRLF & _
"[1]" & @CRLF & _
" 1 string data = "another text in spanish"" & @CRLF & _
"[2]" & @CRLF & _
" 1 string data = ""some text" in english" and "other""" & @CRLF & _
"..." & @CRLF & _
"[2]" & @CRLF & _
" 1 string data = """ & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")