import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[2\\][^=]+?= \"\").*(?=\"\")";
final String string = "[0]\n"
+ " 1 string data = \n"
+ "[1]\n"
+ " 1 string data = \"first spanish text\"\n"
+ "[2]\n"
+ " 1 string data = \"\"some text\"\"\n"
+ "[0]\n"
+ " 1 string data = \"\"\n"
+ "[1]\n"
+ " 1 string data = \"another text in spanish\"\n"
+ "[2]\n"
+ " 1 string data = \"\"some text\" in english\" and \"other\"\"\n"
+ "...\n"
+ "[2]\n"
+ " 1 string data = \"\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}