import Foundation
let pattern = #"(?<=\[2\][^=]+?= "").*(?="")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[0]
1 string data =
[1]
1 string data = "first spanish text"
[2]
1 string data = ""some text""
[0]
1 string data = ""
[1]
1 string data = "another text in spanish"
[2]
1 string data = ""some text" in english" and "other""
...
[2]
1 string data = ""
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)