$re = '/(?<=\[2\][^=]+?= "").*(?="")/';
$str = '[0]
1 string data =
[1]
1 string data = "first spanish text"
[2]
1 string data = ""some text""
[0]
1 string data = ""
[1]
1 string data = "another text in spanish"
[2]
1 string data = ""some text" in english" and "other""
...
[2]
1 string data = ""
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);