const regex = new RegExp('(?<=\\[2\\][^=]+?= "").*(?="")', 'g')
const str = `[0]
1 string data =
[1]
1 string data = "first spanish text"
[2]
1 string data = ""some text""
[0]
1 string data = ""
[1]
1 string data = "another text in spanish"
[2]
1 string data = ""some text" in english" and "other""
...
[2]
1 string data = ""
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}