#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)["'%] # first possible character" & @CRLF & _
"(?:(?<=%)q<)? # if preceded by a % match "q<"" & @CRLF & _
"(?P<name> # the three possibilities excluding the delimiters" & @CRLF & _
" (?<=") [a-zA-Z0-9_.-]+ (?=") |" & @CRLF & _
" (?<=') [a-zA-Z0-9_.-]+ (?=') |" & @CRLF & _
" (?<=<) [a-zA-Z0-9_.-]+ (?=>)" & @CRLF & _
")" & @CRLF & _
"["'>] # closing delimiter"
Local $sString = ""gemname1"" & @CRLF & _
"'gemname2'" & @CRLF & _
"%q<gemname3>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")