import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\"'%] # first possible character\n"
+ "(?:(?<=%)q<)? # if preceded by a % match \"q<\"\n"
+ "(?P<name> # the three possibilities excluding the delimiters\n"
+ " (?<=\") [a-zA-Z0-9_.-]+ (?=\") |\n"
+ " (?<=') [a-zA-Z0-9_.-]+ (?=') |\n"
+ " (?<=<) [a-zA-Z0-9_.-]+ (?=>)\n"
+ ")\n"
+ "[\"'>] # closing delimiter";
final String string = "\"gemname1\"\n"
+ "'gemname2'\n"
+ "%q<gemname3>";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}