re = /["'%] # first possible character
(?:(?<=%)q<)? # if preceded by a % match "q<"
(?P<name> # the three possibilities excluding the delimiters
(?<=") [a-zA-Z0-9_.-]+ (?=") |
(?<=') [a-zA-Z0-9_.-]+ (?=') |
(?<=<) [a-zA-Z0-9_.-]+ (?=>)
)
["'>] # closing delimiter/x
str = '"gemname1"
\'gemname2\'
%q<gemname3>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end