using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[""'%] # first possible character
(?:(?<=%)q<)? # if preceded by a % match ""q<""
(?P<name> # the three possibilities excluding the delimiters
(?<="") [a-zA-Z0-9_.-]+ (?="") |
(?<=') [a-zA-Z0-9_.-]+ (?=') |
(?<=<) [a-zA-Z0-9_.-]+ (?=>)
)
[""'>] # closing delimiter";
string input = @"""gemname1""
'gemname2'
%q<gemname3>";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}