const regex = new RegExp('["\\'%] # first possible character
(?:(?<=%)q<)? # if preceded by a % match "q<"
(?P<name> # the three possibilities excluding the delimiters
(?<=") [a-zA-Z0-9_.-]+ (?=") |
(?<=\\') [a-zA-Z0-9_.-]+ (?=\\') |
(?<=<) [a-zA-Z0-9_.-]+ (?=>)
)
["\\'>] # closing delimiter', 'g')
const str = `"gemname1"
'gemname2'
%q<gemname3>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}