package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`["'%] # first possible character
(?:(?<=%)q<)? # if preceded by a % match "q<"
(?P<name> # the three possibilities excluding the delimiters
(?<=") [a-zA-Z0-9_.-]+ (?=") |
(?<=') [a-zA-Z0-9_.-]+ (?=') |
(?<=<) [a-zA-Z0-9_.-]+ (?=>)
)
["'>] # closing delimiter`)
var str = `"gemname1"
'gemname2'
%q<gemname3>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}