#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*release(-arm)?(-el(9|10))?$"
Local $sString = "pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el9" & @CRLF & _
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el10" & @CRLF & _
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el9" & @CRLF & _
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el10" & @CRLF & _
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el9" & @CRLF & _
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el10" & @CRLF & _
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el9" & @CRLF & _
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el10" & @CRLF & _
"" & @CRLF & _
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el9" & @CRLF & _
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el10" & @CRLF & _
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el9" & @CRLF & _
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el10" & @CRLF & _
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el9" & @CRLF & _
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el10" & @CRLF & _
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el9" & @CRLF & _
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el10" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")