re = /.*release(-arm)?(-el(9|10))?$/m
str = 'pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el10
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end