// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*release(-arm)?(-el(9|10))?$").unwrap();
let string = "pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el10
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}