import re
regex = re.compile(r".*release(-arm)?(-el(9|10))?$", flags=re.MULTILINE)
test_str = ("pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el9\n"
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el10\n"
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el9\n"
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el10\n"
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el9\n"
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el10\n"
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el9\n"
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el10\n\n"
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el9\n"
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el10\n"
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el9\n"
"pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el10\n"
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el9\n"
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el10\n"
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el9\n"
"pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el10\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")