$re = '/.*release(-arm)?(-el(9|10))?$/m';
$str = 'pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);