import Foundation
let pattern = #".*release(-arm)?(-el(9|10))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-release-arm-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-release-arm-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-el10
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el9
pull-ci-openshift-microshift-main-e2e-aws-tests-bootc-arm-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-el10
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el9
pull-ci-openshift-microshift-release-4.23-e2e-aws-tests-bootc-arm-el10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)