package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n+\s*\<`)
var str = `FIRST LINE '<foo>
<bar>
<baz>'
ANOTHER LINE 'lorem ipsim', '<dolor>
<and>
<p>again</p>
</and>
</dolor>'
Expected:
FIRST LINE '<foo> <bar><baz>'
ANOTHER LINE 'lorem ipsim', '<dolor><and><p>again</p></and><dolor>'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}