import re
regex = re.compile(r"\n+\s*\<", flags=re.MULTILINE)
test_str = ("FIRST LINE '<foo>\n"
" <bar>\n"
"<baz>'\n\n"
"ANOTHER LINE 'lorem ipsim', '<dolor>\n"
" <and>\n"
" <p>again</p>\n"
" </and>\n"
"</dolor>'\n\n\n"
"Expected:\n"
"FIRST LINE '<foo> <bar><baz>'\n\n"
"ANOTHER LINE 'lorem ipsim', '<dolor><and><p>again</p></and><dolor>'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")