re = /\n+\s*\</m
str = 'FIRST LINE \'<foo>
<bar>
<baz>\'
ANOTHER LINE \'lorem ipsim\', \'<dolor>
<and>
<p>again</p>
</and>
</dolor>\'
Expected:
FIRST LINE \'<foo> <bar><baz>\'
ANOTHER LINE \'lorem ipsim\', \'<dolor><and><p>again</p></and><dolor>\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end