$re = '/\n+\s*\</m';
$str = 'FIRST LINE \'<foo>
<bar>
<baz>\'
ANOTHER LINE \'lorem ipsim\', \'<dolor>
<and>
<p>again</p>
</and>
</dolor>\'
Expected:
FIRST LINE \'<foo> <bar><baz>\'
ANOTHER LINE \'lorem ipsim\', \'<dolor><and><p>again</p></and><dolor>\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);