import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n+\\s*\\<";
final String string = "FIRST LINE '<foo>\n"
+ " <bar>\n"
+ "<baz>'\n\n"
+ "ANOTHER LINE 'lorem ipsim', '<dolor>\n"
+ " <and>\n"
+ " <p>again</p>\n"
+ " </and>\n"
+ "</dolor>'\n\n\n"
+ "Expected:\n"
+ "FIRST LINE '<foo> <bar><baz>'\n\n"
+ "ANOTHER LINE 'lorem ipsim', '<dolor><and><p>again</p></and><dolor>'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}